AIS receiver driver found----solved,also discussed the general driver issue on Win7/8

Quark-elec AIS receiver and NMEA multiplexer products questions
Post Reply
irmascherkid
Posts: 3
Joined: Thu May 16, 2019 1:44 pm

AIS receiver driver found----solved,also discussed the general driver issue on Win7/8

Post by irmascherkid »

Hi all
i have just purchased the A021 AIS dongle and after loading the drivers from disc and internet i still cant get the ais to show on any of my navigational programs opencpn v4 & v5 / seaclear2 / memory map.
i removed all the drivers and re done the set up but still same out come? the dongle did flash green a few times but now nothing and no ais targets on show even though im on the boat and my neighbours class b ais is showing on marine traffic!
after inspecting device manager i get this ... The drivers for this device are not installed. (Code 28) There is no driver selected for the device information set or element.

so have i done something wrong? i tried on a different laptop also with same result both running windows 7?
any ideas?

thanks

User avatar
admin
Site Admin
Posts: 619
Joined: Tue May 13, 2014 2:50 pm

Re: A021 no driver found

Post by admin »

Can you send us a screen spot of the device drive so we can check if the driver installed properly. Thanks. The latest driver can be download from:
https://www.quark-elec.com/doc/A021_driver.zip

irmascherkid
Posts: 3
Joined: Thu May 16, 2019 1:44 pm

Re: A021 no driver found

Post by irmascherkid »

hi
i have attached some screen shots, if this is not what you are looking for just let me know,
i tried to download and re install from the link you sent but still having same results?
Attachments
screen1.png
screen1.png (165.21 KiB) Viewed 2937 times
screen2.png
screen2.png (165.21 KiB) Viewed 2937 times
screen3.png
screen3.png (138.2 KiB) Viewed 2937 times

User avatar
admin
Site Admin
Posts: 619
Joined: Tue May 13, 2014 2:50 pm

Re: A021 no driver found

Post by admin »

Hello,
I can see the driver hasn't been installed properly.
It looks like your Windows system didn't identify the device ID.
Can you try to install V1.4 or V1.5 version driver please.
It can be download from https://www.st.com/en/development-tools ... 32102.html.
Make sure uninstalled the old driver and then install the new one. Thanks.

irmascherkid
Posts: 3
Joined: Thu May 16, 2019 1:44 pm

Re: A021 no driver found

Post by irmascherkid »

Hi
I have tried again to un install all the drivers and down loaded the driver v1.5 and tried to run again but with same result, also tried down loading and running with firewall disabled with same result? Couldn't find V1.4 !
I know that the dongle does work as i was able to borrow a pc with windows 10 and it installed and it showed ais targets fine!?

User avatar
admin
Site Admin
Posts: 619
Joined: Tue May 13, 2014 2:50 pm

Re: A021 no driver found

Post by admin »


User avatar
admin
Site Admin
Posts: 619
Joined: Tue May 13, 2014 2:50 pm

Re: A021 no driver found

Post by admin »

One of our lovely customers have the same problem on his Windows 7 system. Eventually the issue has been sorted out with the following steps.
Firstly you have to select COM ports,then you get the options… to select as per screen shots.
FROM DEVICE MANAGER, update Drivers, click on Let me pick…. > Next (image1)
Then select the following, version 1.4.0 (image2)
Click next. It seems to install the drivers and recognise the port… (image3)
Attachments
image1
image1
1.png (128.04 KiB) Viewed 2891 times
iamge2
iamge2
2.png (60.44 KiB) Viewed 2891 times
image3
image3
3.png (4.96 KiB) Viewed 2891 times
image3
image3
3.png (4.96 KiB) Viewed 2891 times
image2
image2
2.png (60.44 KiB) Viewed 2891 times

oaSTAR
Posts: 36
Joined: Mon Feb 29, 2016 10:57 pm

Re: A021 no driver found----solved

Post by oaSTAR »

It takes me quite a while to install and get it run on my computer.
I’ve tried any possible drivers for Virtual com port, but no use. Later was found that vendor ID
for device programmed in my dongle mismatch to VID in “inf” file. QK-A021 holds 5770, and “inf” file contains 5740,
well after editing “inf” it works fine. I writing this message just in the case that somebody has the same problem with me.
problem isn't fatal.it seems the whole product is well designed and fabricated. Great device, fast shipping.
Attachments
AIS receiver dongle
AIS receiver dongle
542.jpg (184.62 KiB) Viewed 2801 times

User avatar
admin
Site Admin
Posts: 619
Joined: Tue May 13, 2014 2:50 pm

Re: A021 no driver found----solved

Post by admin »

Alternatively, you can manually install V1.3 version driver. This should solve most of Win7/8 driver issue which shows the error code 28.
The driver can be found from:
http://quark-elec.com/doc/STM_Virtual_C ... r_V1.3.zip

kurt berg
Posts: 13
Joined: Wed Aug 12, 2020 6:37 am
Location: Bindslev Denmark

Re: AIS receiver driver found----solved,also discussed the general driver issue on Win7/8

Post by kurt berg »

I will follow these steps Thankyou

Post Reply